Welcome to the Second Life Forums Archive

These forums are CLOSED. Please visit the new forums HERE

No sounds at all in Second Life

Zorin Frobozz
Registered User
Join date: 21 Mar 2006
Posts: 84
04-24-2006 11:53
1.9.0(21).. suddenly sounds stopped working completely.

I'm seeing a lot of this in the log:

2006-04-24T18:49:13Z WARNING: Could not load data '/Users/zorin/Library/Application Support/SecondLife/cache/dce5fdd4-afe4-4ea1-822f-dd52cac46b08.dsf': This command failed because FSOUND_Init was not called

Any ideas? I already tried renaming the SecondLife configuration directory and starting with a fresh configuration; no help.

No sound works at all, not even streaming.

Thanks,
-Zorin
Zorin Frobozz
Registered User
Join date: 21 Mar 2006
Posts: 84
04-24-2006 13:04
More information...

Sound in all other applications seems to work fine. I saw this in the log when I start Second Life (and before I log in)

2006-04-24T19:58:19Z INFO: LLAudioEngine_FMOD::init() initializing FMOD
2006-04-24T19:58:20Z WARNING: Error initializing FMOD: Error initializing output device.
2006-04-24T19:58:20Z
2006-04-24T19:58:20Z WARNING: Unable to initialize audio engine

This happens with the latest beta client (for the beta grid) as well.

I don't believe I've changed anything on this machine, and it was working fine yesterday.

Strangely, this error also happens on the PPC client running under Rosetta. I'm going to post this in the general Mac discussion forum too.

-Z
Zorin Frobozz
Registered User
Join date: 21 Mar 2006
Posts: 84
04-24-2006 14:54
Problem fixed!

After much poking around on the Internet, I learned what happened. Turns out Audacity reset the default output sample rate on the machine to 96000Hz! FMOD, the sound output plugin used by Second Life, does not like this.

Turns out the solution is right here:

http://docs.info.apple.com/article.html?artnum=300832

As soon as I set the default output sample rate to 44100Hz, sound started working again!

This seems to be a general Mac issue and not related to the universal binary beta client.

-Z